Spark SDK (Build 127) Released

Posted by unknownworlds 13 years ago

We’ve just published a new patch for the Spark SDK. The Spark SDK is the package which includes the level editor for Natural Selection 2, which we’ve made available to everyone who pre-orders the game.

This patch includes fixes for some of the most common crash problems, new features and some new artwork. Here’s the complete list of changes:

  • Added shadows for point lights
  • Added a flag to choose whether a point or spot light casts shadows
  • Added "paint" selection mode (activated by holding down shift in the Select tool)
  • Added Duplicate Selection to Edit menu
  • Added mouse wheel scrolling in the asset browsers
  • Added the graphics adapter name and driver version to the log file
  • Added additional information to the log file when a creating a Direct3D texture fails
  • Added current color and selection indicators for lights
  • Added new ceiling material (refinery_ceiling_04)
  • Added new floor tubes models (refinery_floor_tubes)
  • Added new pipe models (refinery_pipe_03_straight, refinery_pipemods)
  • Added new pipe models (refinery_pipe_03_straight, refinery_pipemods)
  • Added broken vent model (refinery_vent_broken_01)
  • Added broken vent model (refinery_vent_broken_01)
  • Added wall meshes with vent holes in them
  • Changed light selection to be based on its visual representation rather than lighting distance
  • Fixed crash when attempting to setup shadows for spot lights when a shadow map texture was not available
  • Fixed crash bug when the accumulation buffers necessary for rendering could not be allocated
  • Fixed selection bug in move tool for entities
  • Fixed broken ceiling material (refinery_ceiling_03)
  • Fixed broken ceiling material (refinery_ceiling_03)
  • Fixed broken materials on a number of models

If you’ve already installed the Spark SDK, it will automatically detect the update and give you the option to install when the editor is launched. If you haven’t installed it, you can download the installer from here. Note that in order to run the editor you will need your pre-order key.

If you haven’t pre-ordered it and would like to, you can still do so here!

Comments are closed.